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Purpose:

This workshop aims to introduce you to how FIJI and FluoRender
are used to visualize and render fluorescence images.  The 
emphasis is practical - “how to” not “why.”

• Key Concepts in Image Processing and Analysis

• Extending FIJI with Plugins and Automation Macros

• Advanced Quantitative Methods in Image Processing

See the Learning and Outreach section of our website for more 
information:
https://brcf.medicine.umich.edu/cores/microscopy/outreach/

Other workshops will emphasize theory or computation:

https://brcf.medicine.umich.edu/cores/microscopy/outreach/


Installing FIJI

Goto:   https://fiji.sc/

Select version 
for your OS.

*If your computer is HITS ‘Core Imaged’, must install FIJI to the Desktop folder*



Installing FluoRender

Goto:   https://github.com/SCIInstitute/fluorender/releases
Scroll down to find proper executable for your OS…

Latest Manual and Tutorials are also available here. 

* If you are having problems with installation, contact HITS *

https://github.com/SCIInstitute/fluorender/releases


ImageJ is an open source and extensible 

image processing application written in Java in 
1997 (runs on any OS). http://imagej.nih.gov/ij/

What is ImageJ/FIJI?

ImageJ2 is a re-write of ImageJ according to modern programming 
conventions released in 2010.  The typical user won’t see any differences.

FIJI Is Just ImageJ2 with many plugins pre-installed.  

It is also automatically updated with new plugins 
when they are available.

See:  Schindelin et al.  Fiji: an open-source platform for biological-image 
analysis. Nature Methods. 2012.

https://fiji.sc/

http://imagej.nih.gov/ij/
https://fiji.sc/


What is ImageJ/FIJI?

FIJI looks small, but it is very powerful once you know how 
to use it.  

FIJI is also FREE!

FIJI does much more than what we will talk about today. 
Please be curious and explore further on your own!

Today, we will focus on the most common and useful 
commands in the first three menu options.



Display of 2D Images



Several Ways to Open Files in FIJI…

1. Drag and Drop the file onto the FIJI menu bar.

2. For some proprietary file types, you might first see an options 
window…

3. If the image is comprised of many indexed files, use the File -> Import 
-> Image Sequence command.  Use file filtering options as needed.

TRY IT WITH Tissue.tif

TRY IT WITH images in folder Neuron_Slices

TRY IT WITH Neuron_Vesicles.nd2

There are useful options here for advanced 
users, but today we will just press OK.



Common Image File Types

A few (of many) image file types that FIJI will open:

File types are just conventions for how to organize pixel data and metadata 
(other information such as acquisition parameters).  A given software may be 
designed to only understand certain file types, but thankfully FIJI will open 
almost anything!

File Types Purpose

TIF “Tag Image Format”.  Very flexible and understood by many softwares

LIF Leica format; stores meta data so users can ‘reuse’ settings

CZI Zeiss format; stores meta data so users can ‘reuse’ settings

ND2 Nikon format; stores meta data so users can ‘reuse’ settings

AVI A (often compressed) movie format

JPG A compression format for natural images. Generally not for science 
images.



Getting Information About a File

Besides the pixels, images contain other 
descriptive information called ‘meta-data’. 

To display this information, use Image -> Properties…
and Image -> Show Info

TRY IT WITH Neuron_Vesicles.nd2

Scale

Pixel Dimensions

Data Type

Some of this info is also displayed under the image’s title bar:

File size in memory
Time points



Handy Tools…

Drawing shapes on the image

Zooming/Panning the image

Free drawing on the image

Drawing text on the image

Right-click on the buttons to get more options.

TRY IT:
To get a new image:  File -> New -> Image  (Select Type = RGB)
Use: Edit -> Fill and    Edit -> Draw    to paint the shapes and text  



Image Data Types

Common Scientific Image Data Types:

A data type is a low-level description of how image pixel data is stored (not 
how it is organized, which is the file type).  Most file types can contain many 
different data types.  Conversely, a given data type can be contained in many 
different file types.

Data types are important because they limit how an image can/should be 
manipulated and displayed.

Since this workshop is about visualization of fluorescence images, we will care 
mainly about 8-bit, multi-channel images.  (Since a computer monitor can 
display only about 8-bits per channel).

• Channel based:  8-bit, 16-bit, or 32-bit per channel

• Color based:  24-bit RGB, HSB, LAB, Indexed Color



Channel-based vs RGB Color Data Types

Caution:  Fluorescence images should NEVER be stored as RGB Color since the original channel 
information will most likely be lost. (Only exception is if you are making an image purely for visual 
display in a figure). 

A multi-channel image and RGB color image are COMPLETELY DIFFERENT!  
They store data differently and should never be used interchangeably.

Multi-Channel Image RGB Color Image

Purpose: Storing collections of 
monochrome images

Storage of a natural color (white 
light) image.

Channels: Any number [c1],[c2],[c3],…  
Channels are independent and 
can be view separately.

Exactly 3  [c1,c2,c3]. Channels are 
dependent and always viewed 
together.

Bit depth: Any 8-bit only (“24-bit color”)

Pseudo color 
LUT Support:

Yes No, the data IS the color

Issues: Can only be opened using 
dedicated image processing 
software

Opens with any image viewer since 
RGB Color is used by most 
consumer electronics



Monochrome Images

A monochrome image is a matrix of numbers where the number at each 
location in the matrix is proportional to the amount of light present at a 
corresponding location in the sample.

Image PixelsCamera Pixels

Microscope
Computer

The value of each pixel is encoded as a whole number (“intensity”) .

“0”
“104”



Bit-Depth Describes Number of Intensity Levels

Though we typically count in whole numbers (0,1,2,3…9), computers 
represent numbers in base-2 (binary) symbols called bits (0,1).  Bits are 
organized into combinatorial blocks of 8.  Thus, bit-depth describes the 
range of intensity levels that can stored at each pixel.

8 bits can store (2^8) 256 intensity levels, from 00000000 -> 11111111

16 bits can store (2^16) 65,536 intensity levels, from 000000000000000000
-> 1111111111111111

Whole Number Binary Number Data Type

0 00000000 8-bit

107 1101011 8-bit

255 1111111 8-bit

10,345 10100001101001 16-bit

65,534 1111111111111110 16-bit



Working with Monochrome Images

OPEN Neuron_Vesicles.nd2

Hover over the image and look at the Tool Bar’s information panel to see the 
pixel intensity at each location.

Use:  Analyze -> Histogram to get the distribution of pixel 
intensities for the entire image.



How brightly each pixel’s intensity value is displayed on the computer screen 
is determined by a ‘look up table’ (LUT).  A lookup table is a table or equation 
that maps pixel intensities onto screen brightness values.

Displaying Monochrome Images

Pixel 
Intensity

Screen 
Brightness

0 0
32 32
64 64
96 96

128 128
160 160
192 192
224 224
255 255

Table:

Corresponding 
Equation: V = 1*D + 0

D = (m)*S + b, where m (slope) represents ‘contrast’ and b (intercept) 
represents ‘brightness’.

Pixel 
Intensity

Screen 
Brightness

0 0
32 64
64 128
96 192

128 255
160 255
192 255
224 255
255 255

V = 2*D + 0

Display saturated.
DO NOT DO THIS

Table:



Displaying Monochrome Images

Adjust the LUT using Image -> Adjust -> Brightness/Contrast.

Caution:  “Apply” changes the raw intensities to the 
current screen brightness values.  Do NOT do this unless 
you are simply making a figure for visual inspection.

OPEN Neuron_Vesicles.nd2

The LUT is illustrated as a line graph, where x-axis is 
pixel intensity and y-axis is monitor brightness.

• The Min and Max sliders set the range of pixel 
intensity values that will be displayed.

• Auto will guess a good range.

• Set allow you to type in exact values.

• Apply applies the LUT to the image.

Pixel Intensity
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Nonlinear LUTs can be used to specify the pixel intensity  / screen 
brightness relationship (called ‘’).  For engineering reasons, a power law 
relationship is common and the adjustable parameter is an exponent 
called ‘gamma’.

Pixel Intensity
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V = Dg

V = Dg

V = Dg

g >1 

1> g >0 

g = 1

Displaying Monochrome Images

Gamma  < 1 increases relative 
brightness of low intensity pixels.

Gamma  > 1 reduces relative 
brightness of low intensity pixels.

Caution:  Using gamma means the image as displayed 
no longer accurately represents the relation between 
the intensities in the raw image.

TRY IT WITH Neuron_Vesicles.nd2



Color LUTs can be used that assign a color to each pixel intensity in the 
image.

Displaying Monochrome Images

Caution:  Our eyes don’t see red or blue very well.  As possible, use colors from 
the middle of the spectrum that are closer to green. 

Pixel 
Intensity

Screen 
Red

Screen 
Green

Screen
Blue

0 0 0 0
32 32 0 0
64 64 0 0
96 96 0 0

128 128 0 0
160 160 0 0
192 192 0 0
224 224 0 0
255 255 0 0

Red Color LUT:

To apply a color LUT:   Image -> Lookup Tables
To see the LUT:   Image -> Color -> Show LUT
To create a custom LUT: Image -> Color -> Edit LUT

TRY IT WITH Neuron_Vesicles.nd2



Working with Multi-Channel Images

Working with multiple channels is exactly the same as for one channel, only 
now there are multiple channels, each of which can be adjusted separately.

Open Organoid.czi

Use slider a bottom of image window to switch between channels.

Use Image -> Spilt Channels to get the channels as individual images.

Use Image -> Color -> Channels Tool to display selected channels only.

Red Channel Green ChannelMerge



Converting Between Image Data Types

Adjust LUT and then convert to 8-bits / channel.

Converting between data types is done using the Image -> Type menu 
options.

Open Organoid.czi

Caution:  Information is lost during this step, since there are now fewer intensity level 
values per pixel.  For our purposes of visualization, this is not important

Make channels green, magenta, and blue.  Convert to RGB color.
Caution:  Channels are now no longer separable and in general can never be re-separated.  
However, non-image processing software such as Photoshop or other graphic software do 
not support channels and are only designed to work with RGB color, as this is a standard 
format used by commercial cameras.

Try converting back to channels
Why does it fail?



Be careful when displaying in color!

http://starizona.com/acb/ccd/advtheorycolor.aspx

Light-adapted spectral sensitivityDark-adapted spectral sensitivity

We don’t perceive colors equally!  Color perception is brightness dependent 
and brightness perception is color dependent.  Color perception is also 
influence by surrounding colors.



A and B have exactly 
the same intensity!

Even intensity perception is scene dependent.

Even be careful when looking at a single 
monochrome image!

http://starizona.com/acb/ccd/advtheorycolor.aspx

Caution: Though this workshop is about image display, images should NEVER be analyzed by 
looking at them!  Image displays are simply illustrations intended to highlight features established 
through other quantitative means.



Basic Manipulation of 2D Images



Basic Image Manipulations

Change in size
(Scaling)

Change in 
orientation
(Rotation)

Cropping

Besides, changing how pixel intensities are displayed, we may 
also want to change the image’s coordinate system.  There are 
several common ways to do this:



Changing Image Size

Enlargement means creating a finer coordinate system by adding 
new pixels ‘in between’ existing pixels.  New intensity values must 
be created for the new pixels.

5 8 ..

2 4

:

5 ? 8 ..

? ? ?

2 ? 4

:

Double 
image size…

0        1         2

0

1

2

0      0.5     1      1.5     2     2.5
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Open a single slice from Neuron_Slices folder

Use:  Image -> Scale.  Scale values >1 are enlargement.
Scale values <1 are reduction.

(Scale = 2x)

Caution:  These operations create a new image with more/less pixels.   This is NOT ‘zooming’, 
which merely enlarges the display of the image on the monitor.



‘Nearest neighbor’ method creates the new intensity values by 
duplicating the nearest measured intensity value (enlargement) 
or by simply removing pixels (reduction) as needed.

Original

Nearest Neighbor

Nearest Neighbor  looks pixelated
because no new intensity values 
are created, but it displays only 
acquired data.

Nearest Neighbor Scaling



‘Bicubic’ converts fits a curve to a 4x4 neighborhood of known 
intensity values and then samples from this curve.

Original

Bicubic

Bicubic looks smooth due to the 
interpolated intensity values, but most 
of the image consists of interpolated 
values, not acquired data.

Bicubic Scaling



Image Rotation (center point)

An image’s coordinate system can be rotated.  Unless the 
rotation is 90 degrees, the rotated coordinate system will not 
align with the coordinate system of the screen.  Again, some 
scheme is needed to create new intensity values.

Rotation θ :

y1

x1

x2 y2

Display coordinates
(fixed by monitor)

x2 = cosθ (x1) – sinθ (y1)
y2 = sinθ (x1) + cosθ (y1)

Image coordinates
(original)

Image coordinates
(rotated)

Use:  Image -> Transform -> Rotate TRY IT



Other Coordinate Operations

Use:  Image -> Crop

Image -> Transform -> Flip

Image -> Transform -> Translate

TRY IT



Display of 3D+ Images



How Microscopic 3D Images Are Acquired
In microscopy, 3D images are acquired via collecting a sequence of adjacent 
2D images that have limited depth of field.  Such a collection of slices is called 
a ‘z-stack’ and can be represented as a 3-dimensional matrix.  

Thick
Sample

Move 
objective in z 

relative to 
sample

Slice 1                Slice 2                Slice 3

Slice 4                Slice 5                Slice 6

Slice 7                Slice 8                Slice 9

Slice1
Slice2
Slice3
….



Computer screens are inherently 2D, so the 3rd dimension of information 
in an image is difficult to visualize.  The 3D data must be collapsed into 2D, 
and information is always lost during this step.

Common display options:

2D Displays of 3D Images

• Project the 3D data onto a 2D plane.  This works OK as long as the 
signal is sparse (not highly overlapping in the z direction).

• Interactively visualize the collection of 2D slices one-at-a-time 
(scroll through the planes).  With practice, this can work well.

• Create a 3D rendering of the data.  Always throws away or obscures 
internal information.



Intensity projections are some mathematical operation on the pixel intensities 
along a set of parallel ray paths through the data.

3D dataset

2D Projection

Intensity Projections

Use:  Image -> Stacks -> Z Project…

Max Intensity (show brightest pixel) 
and Sum Slices (sum all pixels) makes 
sense for fluorescence images where 
signal is bright and background is 
dark. 

Caution:  Max Intensity projection does NOT preserve total intensity and should never be 
used prior to measuring / displaying intensity information.  It is strictly a ‘structural’ display.

Open Organoid.czi



Rotating Intensity Projections

Though a projection is just a 2D image, making a projection from many 
different angles and playing them back as a movie gives some 
impression of depth due to parallax.  

Use:  Image -> Stacks -> 3D Project…

FIJI lacks a good interactive 3D Viewer.  We will use FluoRender for this 
later!  But, for a quick interactive 3D view try:   Plugins -> 3D Viewer

Caution:  3D Viewer is very limited and often freezes/crashes.  It is not 
recommended for most purposes.

Try it with Organoid.czi



‘Orthogonal slices’ displays a set of 3, 2D images that are each from 
mutually perpendicular planes through the 3D volume.  The three planes  
intersect at the location of the cursor.  The raw pixel data is shown directly, 
though only a small fraction of data is seen at any one time.

Orthogonal slices

Sagittal

xy

xz

yz

3D dataset

Orthogonal planes

xy

xz

yz

Orthogonal Slices

Use:  Image -> Stacks -> Orthogonal Views

Try it with Organoid.czi



Saving Images in FIJI



Image File Type Considerations

After opening, the image must be saved as some file type.

• If you only adjusted LUTs, the data has not been changed so there is 
no need to re-save.  

• If the data type (bit-depth) or raw pixel values have been changed, 
then re-save as a separate file so as not to lose the raw data.

File Type Purpose

TIF Precisely stores all pixel values.  Compatible with all data types and 
any number of channels / dimensions.  Usually the best option.

JPG A lossy (data lost) compression format designed for natural (white 
light) images. Does not support channels (will get whatever channels 
are displayed).  Generally should not be used for fluorescence images. 
Journals will not accept.  Could be used if goal is to create a quick 
snapshot to email or use in a presentation.  Set compression level 
using Edit -> Options -> Input/Output

AVI A movie format.  Typically uses lossy compression in space and time.



Bitmap vs JPG Compression

Bitmaps (such as TIF) save each pixel value individually.  JPG compression 
splits an image into blocks and then discards certain colors and details 
within each block to approximate the original image.  Approximation may 
be very poor at high compression levels.

Notice ‘blockiness’.  
Compression occurs 
within each block.

BitmapJPG Compression



Getting Help with FIJI After Today…

1. The online manual is excellent and detailed…
(but does not cover plugins.. Plugins have their own websites)

https://imagej.nih.gov/ij/docs/guide/146-30.html

2.  Type the name of the menu command into the toolbar…

3.  Google it…

5.  microscopy@umich.edu

* If you are having problems with installation, contact HITS *

4.  Attend other workshops that cover more advanced topics

https://imagej.nih.gov/ij/docs/guide/146-30.html


FluoRender for Interactive 3D 
Rendering and 3D Movies



What is FluoRender?

A major drawback of FIJI is that there is no great option for 3D 
rendering of multichannel volume views.  FluoRender fills this gap.

FluoRender is an open source (in C) 
application specifically designed for 
3D rendering of multichannel 
volume views.

http://www.sci.utah.edu/software/fluorender.html

See:  Wan et al. FluoRender: joint freehand segmentation and visualization 
for many-channel fluorescence data analysis. BMC Bioinformatics. 2017.

FluoRender does much more than what we will talk about 
today.   Please be curious and explore further on your own!

http://www.sci.utah.edu/software/fluorender.html


What is a ‘3D Rendering’?

A 3D rendering is a 2D display created in a way that provides the illusion of 
depth.



True 3D images require each eye be presented with a slightly different view 
(called binocular disparity).  We will not cover true 3D methods today.

Key Features of a 3D Rendering

Features that provide the illusion of depth are perspective, 
shading, and parallax.  These are typically user adjustable. 

• Perspective:  Parts of an object more distant from the viewer in 
the display space are drawn relatively smaller, according to 
vanishing points.  FluoRender uses 3 vanishing points, one for each 
axis of the data.

• Shading:  More distant objects are relatively dimmer.  (Which is 
distinct from shadowing, where objects cast simulated shadows).

• Parallax: Upon interaction, objects move relative to one another 
depending on their relative distance from each other.



FluoRender GUI Overview

Opening/Saving

Rendering Groups

Recording Movies
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FluoRender GUI Overview

Opening Data Files.  Not nearly 
as flexible as FIJI, so stick with 
TIF.  (Can also bridge to FIJI).
Use 8-bit images to make files 
smaller.

Opening/Save Project.  A 
“project” is a rendering that you 
have created in FluoRender.

Only option of note for 
today is ability to set a 
background gradient.

OPEN Tissue.tif



Working with Channels

Turn individual channels on/off, either 
individually or as groups.

Create multiple render views.

(The paintbrush tools are for making 3D 
selections)

Set inter-channel relations.  ‘By  depth’ will treat data 
as objects that occlude.  ‘As composite’ will create 
objects that merge.



Gamma: Relative display of 
dimmer vs brighter intensities.

Adjusting Channel Specific Displays

Saturation:  How colorful.

Luminance:  How bright.

Alpha:  Relative ‘transparency’ 
of pixels along the depth of the 
dataset.

MIP: Show maximum intensity projection.

Color Map: Use spectral lookup tables.

Sample Rate: Scaling of data before display 
on screen. Speeds up large files, at loss of 
data resolution.  (Larger values = fewer 
pixels).

Spacing:  Spacing of data in screen space.  
Usually z resolution is worse than xy so z 
should be larger as appropriate.TRY IT



Making Movies

Go to Advanced tab…

Press Add to record the current 
view.  What you see on the 
screen is what you will get.

Frames per second 
that the movie will 
play at.  10-30 fps 
recommended.

Press Save when you 
are finished at want to 
create the movie.

Inbetweens is the number of 
frames used to interpolate 
between views and so also 
sets timing.

TRY IT



Getting Help with FluoRender After Today…

1. The FluoRender home page has a complete manual 
and video tutorials...
http://www.sci.utah.edu/software/fluorender.html

2. Read the help file in the menu bar.

5.  microscopy@umich.edu

4.  Attend other workshops that cover more advanced topics

3.  Google it…

http://www.sci.utah.edu/software/fluorender.html


Thank you!




