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Section 2 

Formatting 

By the end of this Section you should be able to: 

Split Windows 

Use Conditional Formatting 

Use Format as a Table 

Use Paste Special 

Transpose Data 

Copy and Move Sheets 

 

 

To gain an understanding of the above features, work through the Driving 

Lessons in this Section. 

For each Driving Lesson, read the Park and Read instructions, without 

touching the keyboard, then work through the numbered steps of the 

Manoeuvres on the computer. Complete the Revision Exercise(s) at the end of 

the section to test your knowledge. 
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Driving Lesson 4 - Split a Window 

 Park and Read 

Split is similar to freeze panes except that the individual panes can be scrolled 
to show different information in each pane. 

 Manoeuvres 

1. Open the workbook Retail (see page 4 - Downloading the Data Files for 
the location). 

2. Split is created at the active cell position using the Ribbon. Click on cell 

F8. Display the View tab and then click the Split button , in the 
Window group. The worksheet is now split into four areas, all displaying 
the same worksheet. 

3. Move the active cell to the right and up a few cells, using the arrow keys. 

4. Use the four scroll bars to display different parts of the worksheet to 
create four different views of the same worksheet - very useful if using a 
large worksheet. 

5. The split can be moved by clicking on the split lines and dragging them 

when  appears. Drag the vertical split to the left to display only 2 
columns in the left panes. 

6. To remove the Split, click the Split button again. 

7. Split can also be created using the split boxes at the top or right of the 
Scroll Bars. 

 

8. Drag the Horizontal Split button at the top of the vertical scroll bar down 
to between rows 7 and 8. Drag the Vertical Split button at the right of the 
horizontal scroll bar down to between columns E and F. This achieves the 
same split as created using the Ribbon. 

9. An alternative method to remove a single split is to double click on the 
split line or the split box. Remove the horizontal and then the vertical split. 

10. Leave the workbook Retail open for the next Driving Lesson. 

Horizontal 

Split box 

Vertical 

Split box 
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Driving Lesson 5 - Conditional Formatting 

 Park and Read 

As well as applying formatting to certain cells, it is possible to apply different 
formatting to cells depending on the values within those cells. Selected cells 
can be compared to a value, or the results of a formula, to decide which format 
should be used. This is called Conditional Formatting. 

Multiple conditions can be used to determine the formatting for the same cell, 
so for example, a cell could be coloured red if it is below a certain value and 
blue if it is greater than another value. 

 Manoeuvres 

1. Open the workbook Retail, if it is not already open. 

2. Highlight the Turnover figures, the range B4:M4. 

3. With the Home tab displayed, from the Styles group, select Conditional 
Formatting. 

4. Select New Rule. The New Formatting Rule dialog box is displayed. 

5. From the Select a Rule Type box click on Format only cells that 
contain. 

 

6. In the drop down criteria box (between) select less than or equal to. 

7. Enter the value 19000 in the next box. 

 
 
 

continued over 
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Driving Lesson 5 - Continued 

 

 If entering a formula in the value box remember to start with = 

8. Click the Format button and select the font colour red. Click OK. Click OK 
again to apply the rule. 

9. To add another condition to the same range, click the Conditional 
Formatting icon and select New Rule. Select Format only cells that 
contain, again. Select greater than and enter 25000 in the next box. 
Format the text to be bold and blue. Click OK and OK again to apply the 
formatting. 

10. Highlight the range B14:M14, apply the conditional formatting, values less 
than the average of the range =Average($B$14:$M$14). Format the 
range with a pale yellow cell shading using the Fill tab and More Colors 
option. Click OK, OK and OK again. 

11. To remove Conditional Formatting, select the range B4:M4, click 
Conditional Formatting and select Manage Rules. 

 

 The current selection has two rules applied to it. To view all the rules, select 
This Worksheet from the Show formatting rules for box. 

12. Select the Cell Value > 25000 rule and click the Delete Rule button, 

. Click OK. All values of over 25000 should now not be blue 
or bold. 

13. Experiment with adding and removing conditional formats to highlight 
results in a way that had not been possible before. 

14. Close the workbook without saving. 
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Driving Lesson 6 - Format as Table 

 Park and Read 

There is a set of pre-defined worksheet formats to enhance the appearance of 
a worksheet, via the Home tab Styles group, Format as Table command. 

 Manoeuvres 

1. Open the workbook Budget. 

2. Highlight the range A1:N14 and on the Home tab, in the Styles group, 
click Format as Table. 

3. There is a list of the available Table Formats, covering Light, Medium 
and Dark options. Scroll through the list of Table Formats. Select Table 
Style Light 2. 

 

4. Click OK to confirm the range that is to be formatted. 

5. The sheet is now formatted in the Light 2 style. A Design tab is displayed 
on the ribbon, showing various groups for different types of formatting. 

6. To change the table format, select an option from the Table Styles group 
on the Design tab. Click the More drop down (shown below) to display all 
the available styles. The sheet displays each format as the mouse passes 
over it. 

 

7. To remove the table format, with the range A1:N14 selected, click the 
More button in the Table Styles group on the Design tab and then select 
Clear. 

8. With a filled cell selected, display the Data tab and click the Filter button 
to clear the filter buttons. 

9. Close the workbook without saving. 

More 
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Driving Lesson 7 - Paste Special 

 Park and Read 

When using Copy and Paste or Cut and Paste, the default is to paste the cell 
exactly as it was originally. Paste Special is used to paste cell information 
when a complete copy is not required. For example, Paste Special can: 

• Paste only formulas, values or formats. Pasting values from cells that 
contain formulas is a way of fixing the data, as it will never then be 
recalculated. 

• Combine ranges using an operation, e.g. adding, subtracting, etc. 

• Transpose ranges (change a spreadsheet round by converting rows to 
columns and columns to rows). 

• Paste links to the original data (covered in a later section). 

 Manoeuvres 

1. Open the workbook Finances. 

2. Highlight the range A1:N1. Change the range to italic and the font colour 
to blue. 

3. To paste this formatting to another range, click the cell A1 and in the 
Home tab, Clipboard group, click the Copy button. 

4. Highlight the range A2:A16 and select the Paste drop down arrow. 

5. Many paste options are displayed in the drop down panel, but for the 
purposes of this exercise, select Paste Special to display the Paste 
Special dialog box. 

 

6. Under Paste select the Formats option and click OK to paste the 
formatting. The cell border from A1 is pasted as well. Remove the 
unwanted borders to match those in column B. 

continued over 
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Driving Lesson 7 - Continued 

7. Open the workbook Outgoings. 

8. Select the range A1:L10 and click on the Copy button. 

9. Click on the Excel button on the Taskbar and then select the Finances 
workbook to make it active. 

10. Click on cell B5. Click the Paste button to paste the contents normally. 

11. Data can be pasted using a mathematical operation. Open the file Income 
and highlight the range A1:L2, the income figures. 

12. Click the Copy button. 

13. Switch back to Finances using the Taskbar. 

14. The income figures are to go into the range B2:M3 but this range already 
contains data, which would be overwritten if a normal paste was used. To 
keep the original data, select cell B2 then click the Paste drop down and 
select Paste Special. 

15. Under Operation click Add to add the two sets of figures together, then 
click OK. The data is now combined. 

 The Add operation was used in this example. Subtract, Multiply and Divide 
work in the same way. 

16. It may be required to convert formulas to values because the numbers are 
final, e.g. a VAT return or expenditure after the month end, etc. Using the 
Finances workbook, January has ended and the figures in column B are 
required to be converted to values. Check the cells B4, B15 and B16 to 
see that they contain formulas. 

17. Select the range B2:B16. 

18. Click Copy, then click the Paste drop down and select Paste Special. 

19. Under Paste, select the Values option and click OK. Click away from the 
selection. 

20. Check that the cells B4, B15 and B16 contain values. 

 Remember that this process removes formulas and therefore the worksheet 
cannot be used again. If repeated use is required, create and use a template. 

21. Save the workbook as Finances2 and close it. 

22. Close the workbooks Income and Outgoings without saving. 



ECDL Advanced  Section 2 Formatting 

Excel 2010 20 © CiA Training Ltd 2010 

Driving Lesson 8 - Transposing Data 

 Park and Read 

It is sometimes necessary to change the way data is stored in a worksheet. 
Data stored in rows may be needed in columns and vice versa. This process is 
called Transposing Data. 

 Manoeuvres 

1. Open the workbook Transpose. The Result column is needed in a row. 

2. Select the range B3:C17, then select to Copy the range. 

3. Move to A20 and click the Paste drop down and select Paste Special. 
Check the Transpose box. 

 

4. Click OK. Press <Esc> to exit the copy command. 

5. The data is now shown in rows. Notice that the formats, i.e. the borders, 
have also been copied. This could have been avoided by selecting to 
paste just Values in the Paste Special dialog box. 

6. Transpose the range B3:C17, with values only, to A23. 

7. Close the workbook without saving. 

8. Open the workbook Budget. 

9. Transpose the range A1:N14 to cell A18.  

10. The borders are not appropriate. Undo the paste and transpose the range 
again, this time pasting only values.  

11. Highlight the new range and add new borders as appropriate. 

12. Check the formulas and print a landscape copy of the worksheet on one 
page. 

13. Close the workbook without saving. 
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Driving Lesson 9 - Copying and Moving Sheets 

 Park and Read 

Sheets within a workbook can be moved or copied within the same workbook or 
to a different workbook. 

 Manoeuvres 

1. Open the workbook Divisions. 

2. Sheets can be moved and copied within the same workbook by dragging 
the sheet tab with the mouse. Move the North Midlands sheet to 
between South Wales and Midlands by clicking and dragging the tab to 
the correct position (the black triangle always shows where the sheet will 
be inserted). More sheets will appear when the cursor reaches the end of 
the displayed sheets. 

3. Move the North West sheet to between North and North East. 

 Use the Sheet navigation buttons to locate the sheets that are not visible. 

4. A sheet is copied within the same workbook by holding <Ctrl> while 
dragging the sheet tab. To make a copy of the North sheet, hold down 
<Ctrl> and click and drag the North sheet tab across to the right, next to 
North. Release the mouse button first before <Ctrl>. 

 The name of the copied sheet is North (2). Duplicate sheet names are not 
allowed. A sheet is renamed by double clicking on it and entering a new name. 

5. If a sheet is to be moved or copied to another workbook the shortcut 
menu is used. Right click on the North (2) sheet tab. 

 

6. This menu controls all the actions relating to sheets. Select Move or 
Copy. 

continued over 

Sheet 

Navigation 

buttons 
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Driving Lesson 9 - Continued 

 

 This above dialog box can also be displayed by using the Home tab, Cells 
group, Format button then under Organize Sheets, Move or Copy Sheets. 

7. To create a copy the Create a copy box is checked, otherwise the sheet 
is moved. Check the Create a copy box. 

8. To move or copy to a different workbook, select from the To book box. 
Drop down the list and select (new book). 

 To move or copy to an existing workbook it must already be open, so it is 
displayed in the To book box. 

9. The Before sheet box is empty for a new workbook. An existing one 
would display all the sheets for a selection to be made on the placement. 
Click OK. 

10. A new workbook is started with just the sheet North (2) in it. Display the 
Divisions workbook and check that North (2) is still in this book and that 
it was copied. 

11. Close both workbooks without saving. 
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Driving Lesson 10 - Revision: Formatting 

This is not an ECDL test. Testing may only be carried out through certified 

ECDL test centres. This covers the features introduced in this section. Try not to 

refer to the preceding Driving Lessons while completing it. 

1. Open the workbook House. 

2. Format the range B2:N16 as currency with two decimal places. 

3. Freeze the column and row titles. 

4. Scroll off the screen to check that the titles are frozen. 

5. Format the whole worksheet in Table Style Medium 3. 

6. The screen is cluttered, change the row height of rows 2 to 16 to 15.00 
units (20 pixels). 

7. The screen is now cluttered with zeros, reformat the range B2:N16 as 
Currency with no decimal places, to remove some of them. 

8. Apply conditional formatting to the range B16:N16 the accumulated 
savings row, to display amounts greater than 1000 to be bold and 
displayed in blue text and saving levels under 0 in bold and displayed in 
red text. 

9. An unexpected windfall comes in the form of a £500 pay bonus in 
February. Make the necessary change. Note the effects of the conditional 
formatting on row 16. 

10. Highlight the range A1:N16 and using paste special make a copy on a 
new sheet, but paste only the values. 

11. Check the cells in rows 4, 15 and 16 that contained formulas but are now 
just numbers. Change cell B2 to 0. It has no impact on any other cells. 

12. Save the workbook as House2. 

13. Close the workbook. 

 

 

 

 

 

 

If you experienced any difficulty completing this Revision refer back to the 

Driving Lessons in this section. Then redo the Revision. 

Once you are confident with the features, complete the Record of Achievement 

Matrix referring to the section at the end of the guide. Only when competent 

move on to the next Section. 
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Section 9 

Scenarios 

By the end of this Section you should be able to: 

Create Scenarios 

Use, Edit and Delete Scenarios 

Create Scenario Summary Reports 

 

 

 

 

 

 

To gain an understanding of the above features, work through the Driving 

Lessons in this Section. 

For each Driving Lesson, read the Park and Read instructions, without 

touching the keyboard, then work through the numbered steps of the 

Manoeuvres on the computer. Complete the Revision Exercise(s) at the end of 

the section to test your knowledge. 
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Driving Lesson 38 - Creating Scenarios 

 Park and Read 

When a worksheet is used as a model, certain key input values are varied to 
see the effect on the resulting solutions. Separate versions of the worksheet, 
showing different input values and solutions, can be saved as Scenarios. This 
helps in “What-If?” situations, where various solutions can be named and be 
displayed to compare, for example, the best and worst cases. 

 Manoeuvres 

1. Open the workbook Food, which shows the ingredients available to make 
3 products and the profit from each product. Varying the production mix 
for each product (F5:H5) will produce different total profit. For the first 
model ensure that the cells F5:H5 are all 0. 

2. Highlight the range F5:H5. Display the Data tab, and from the Data Tools 

group, click . Select Scenario Manager. 

3. In the Scenario Manager dialog box, click Add and enter the Scenario 
name as Worst. Make sure the Changing cells are F5:H5, then click 
OK. 

4. Leave the values of the three changing cells as 0 and click OK. Worst is 
now displayed in the Scenario list. 

5. The next scenario will be a guess to try and maximise the profit. Click 
Add, enter the name as Guess and click OK. Enter the values of the 3 
cells as 100, 120 and 110. 

 

6. Click OK. Click Show to see the results with these values. 

7. The next scenario will be another guess to try and maximise the profit. 
Click Add, enter the name as Guess2 and click OK. Enter the values of 
the 3 cells as 150, 150 and 160. Click OK. 

8. Click Add again, enter the name as Best and click OK. This Scenario will 
use figures that have been calculated elsewhere (using Solver - not 
included in this syllabus) to produce the best possible value of Profit, 
G17. Enter the values of the 3 cells as 159, 167 and 200, and click OK. 

9. Click Close. Four scenarios have now been created. Save the workbook 
as Scenario and leave it open. 
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Driving Lesson 39 - Using, Editing and Deleting 

Scenarios 

 Park and Read 

Once a set of Scenarios have been created, they can be viewed by selecting 
the required scenario from the list. Scenarios can also be edited and deleted 
using the Scenario Manager dialog box. 

 Manoeuvres 

1. The workbook Scenario should still be open. If not, open it. 

2. Display the Scenario Manager from the What-If Analysis drop down. 
The four created scenarios are displayed in the list. 

 

3. The scenario Guess2 is not wanted, to delete it, click on Guess2 and 
then click Delete. The Guess2 scenario is removed from the list. 

4. Select Best then select Show (the dialog box may have to be moved to 
see the values on the worksheet). The values and the solution for the 
Best scenario are now displayed. Note that most of the ingredients are 
used. Make a mental note of the Total Profit. 

5. Show the Guess scenario. Note the Total Profit now. 

6. Show the Worst scenario, click Edit and OK. The worst scenario can now 
be changed. Change the values so that they are all 50. Click on OK. 

7. Click Show to view the results then close the Scenario Manager dialog 
box. 

8. Save the workbook using the same name and leave it open. 
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Driving Lesson 40 - Scenario Summary Report 

 Park and Read 

A Scenario Summary Report is a report that lists all the scenarios created for 
a worksheet, along with the result cells. 

 Manoeuvres 

1. The workbook Scenario should still be open. If not, open it. 

2. Display the Scenario Manager. Click on Summary.  

3. The Result cell is the Total Profit, G17. Click on the cell G17. Move the 
dialog box if necessary. 

 

4. Click OK. The Summary Report is now displayed. 

 

5. The report shows the values of the changing cells and the result cell for 
each scenario. An outline view, is provided, allowing certain rows and 
columns to be grouped or un-grouped. The outline can be manipulated to 
change the view of the data. The details of this process are covered in the 
Adding Sub Totals Driving Lesson. 

6. Note that the report is created on a separate sheet called Scenario 
Summary within the current workbook. 

7. Save the workbook using the same name and then close it. 
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Driving Lesson 41 - Revision: Scenarios 

This is not an ECDL test. Testing may only be carried out through certified 

ECDL test centres. This covers the features introduced in this section. Try not to 

refer to the preceding Driving Lessons while completing it. 

 

1. Open the workbook Mailshot. 

2. The range C7:C9 should be empty, if not delete the contents of the range. 

3. Display the Scenario Manager and add the scenario: Guess1 with the 
values for C7:C9 as 800, 700 and 500. 

4. Add the scenario: Guess2 with the values for C7:C9 as 1000, 600 and 
400. 

5. Add the scenario: Guess3 with the values for C7:C9 as 750, 750 and 500. 

6. The three Scenarios are now named. Display Guess2. 

7. Change the orientation to Landscape and print a copy of the worksheet. 

8. Use the Scenario Manager to produce a Scenario Summary, the Result 

Cell is I11. 

9. Print a copy of the Scenario Summary. 

10. Display Sheet1 and use the Scenario Manager to delete the Scenario 
Guess3. 

11. Save the workbook as Mailshot Scenarios. 

12. Close the workbook. 

 

 

 

 

 

 

 

 

If you experienced any difficulty completing this Revision refer back to the 

Driving Lessons in this section. Then redo the Revision. 

Once you are confident with the features, complete the Record of Achievement 

Matrix referring to the section at the end of the guide. Only when competent 

move on to the next Section. 


