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Introduction

This document describes a step-by-step procedure in order to create certificate templates on
Windows Server-based Certification Authorities (CA), that are compliant with X.503 extension
requirements for every type of Cisco Unified Communications Manager (CUCM) certificate.

Prerequisites

Requirements
Cisco recommends that you have knowledge of these topics:

- CUCM version 11.5(1) or later
- Basic knowledge of Windows Server administration is also recommended

Components Used
The information in this document is based on these software and hardware versions:

- The information in this document is based on CUCM Version 11.5(1) or later.
- Microsoft Windows Server 2012 R2 with CA services installed.

The information in this document was created from the devices in a specific lab environment. All of
the devices used in this document started with a cleared (default) configuration. If your network is
live, ensure that you understand the potential impact of any command.

Background information



There are five types of certificates that can be signed by an external CA:

Certificate  Use Impacted Services
Presented at secure device
registration, can sign Certificate
Trust List (CTL)/Internal Trust List - Cisco Call Manager
Callmanager (ITL) files, used for secure - Cisco CTIl Manager
interactions with other servers such - Cisco TFTP
as secure Session Initiation
Protocol (SIP) Trunks.
- Cisco Tomcat
- Single Sign-On (SSO)
- Extension Mobility
- Corporate Directory

Presented for Secure Hypertext
tomcat Transfer Protocol (HTTPS)
interactions.

Used for backup file generation, as
well as IP Security (IPsec)
ipsec interaction with Media Gateway
Control Protocol (MGCP) or H323
gateways.
Used to generate Locally
CAPF Significant Certificates (LSC) for
phones.
Used to create a connection to the
Trust Verification Service (TVS),
TVS when the phones are not able to -Cisco Trust Verification Service
authenticate an unknown
certificate.

- Cisco DRF Master
- Cisco DRF Local

- Cisco Certificate Authority Proxy
Function

Each of these certificates has some X.509 extension requirements that need to be set, otherwise,
you can encounter misbehaviours on any of the aforementioned services:

Certificate X.509 Key Usage X.509 Extended Key Usage

- Digital Signature
Callmanager - Key Encipherment
- Data Encipherment

- Web Server Authentication
- Web Client Authentication

- Digital Signature
tomcat - Key Encipherment
- Data Encipherment

- Web Server Authentication
Web Client Authentication

- Digital Signature - Web Server Authentication
ipsec - Key Encipherment - Web Client Authentication
- Data Encipherment - IPsec End System

- Digital Signature
CAPF - Certificate Sign

- Key Encipherment

- Digital Signature
TVS - Key Encipherment

. Data Encipherment '

- Web Server Authentication
- Web Client Authentication

- Web Server Authentication
Web Client Authentication

For more information, reference the Security Guide for Cisco Unified Communications Manager



https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/security/12_5_1/cucm_b_security-guide-1251/cucm_b_security-guide-1251_chapter_011101.html?bookSearch=true#reference_0084C33783A0CE6C8A1097015629BEF7

Configure

Step 1. On the Windows Server, navigate to Server Manager > Tools > Certification Authority,
as shown in the image.
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Step 2. Select your CA, then navigate to Certificate Templates, right-click on the list and select
Manage, as shown in the image.
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Callmanager / Tomcat / TVS Template



The next images display only the creation of the CallManager template; but the same steps can be
followed for creating the certificate templates for the Tomcat and the TVS services. The only
difference is to ensure the respective service name is used for each new template during step 2.

Step 1. Find the Web Server template, right-click on it and select Duplicate Template, as shown
in the image.
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Step 2. Under General, you can change the certificate template’s name, display name, validity,
etc.

Superseded Templates |  Btensions | Seauty
Compatiity | General | Raquest Handing | Cryptography | Key Atiestation
Template daplay nama:
|CalManagar CLICM |
Templals namea:

(CalManagar CLCM
Visbdity parod: Riarwal passicd
L Sljean | L 6f|wosks v
[T Publsh cestificate in Actrve Directory

Do neot autoenalically reenmd i a duplcate centificabe mests in Actve

Drecion

| 0K || Cocel || Moy || Hep |

Step 3. Navigate to Extensions > Key Usage > Edit, as shown in the image.



Compatibity | Genersl | Request Handing | Cnptography | Key Attestation
Sudincd Name Syt I Facparemeds
Superseded Torpistes Exensons Securty

To modify an exension. sslect &. and then ook B8

Extensions included in this template;
Applcation Policies

Bamec Conslrainty

Tempiate Infomation
Essumnce Polbcies

Descnipbion of Key Lisage:

Digital sigrasture
Ao By machangs anly with lowy sncnplion
Cirtical mdarmmion.

| Ok || Cacel || Mook || Heb |

Step 4. Select these options and select OK, as shown in the image.

- Digital signature
- Allow key exchange only with key encryption (key encipherment)
- Allow encryption of user data



Properties of New Template [x]

Compatbdty | General IIFIun.-llltl-hnlm | Cryptography | Key Attestation

Spscify the mequined soratunes and sscunty optiona for & key uags
=g

Signatune

[+ Digtal signature

(] Sgnature is proof of origin incrrepudiation)

|| Centificate signing

[ |CAL sigring

Encryption

i) Ao ey eschangs without key snchyplion sy agresment)

@) Mhow key exchange only wit key encryption feey enciphement)
] Ao emcryphion of user dats

[+ Maskoa this eatension crtical

Lok || Cocel || sty || Heo |

Step 5. Navigate to Extensions > Application Policies > Edit > Add, as shown in the image.



Compatibity | General | Request Handing | Cryptography | Key Attestaon
Subject Name | | Regquirements
Superseded Templates Bdensions Securty

To modify an exdension. select & and then click Edi.

Exi enisions included in this template:




WME&HMammh&

Application policies:
Server Authentication

Edit... i Remove

|| Make this extension critical

Step 6. Search for Client Authentication, select it and select OK on both this window and the
previous one, as shown in the image.



| ok || Cancel || Aol || Heb |

Step 7. Back on the template, select Apply and then OK.



Compatiblty | General | Request Handing | Cryptography | Key Atestabon

SubectName | Server Rlequirements
Superseded Templstes | Edensors Secuty

T modiy an edension, sslect i, and then ook BdiL.

Extensiors included in the bermplats:

Descrpton o Appheabion Poboss

Chant Authentication ”
Carver Authaniicabion

e =

Step 8. Close the Certificate Template Console window, and back on the very first window,
navigate to New > Certificate Template to Issue, as shown in the image.
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Step 10. Repeat all previous steps to create certificate templates for the Tomcat and TVS services

as needed.

IPsec Template

Step 1. Find the Web Server template, right-click on it and select Duplicate Template, as shown

in the image.
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Step 2. Under General, you can change the certificate template’s name, display name, validity,
etc..

SubjectMame | Server | lssuance Fequisments
Superseded Templates |  Edensons | Securty
 Compatiity | General | Raguest Handing | Cryptopraghy | Key Attestation

Tesmplate: diaplay nams:
(IPSEC CUCM

Tamplsts narme:
(IPSEC CUCM

Winhdity pericd.: Fenevwal perdod.

T [ B [wesss

[ Prusbesh costficate in Active Dirsclory

|| D ot stomatically reereol F a dupbcale ceficate exdsls in Active
Dreciory

Step 3. Navigate to Extensions > Key Usage > Edit, as shown in the image.



Compatibity | Genersl | Request Handing | Cnptography | Key Attestation
Sudincd Name Syt I Facparemeds
Superseded Torpistes Exensons Securty

To modify an exension. sslect &. and then ook B8

Extensions included in this template;
Applcation Policies

Bamec Conslrainty

Tempiate Infomation
Essumnce Polbcies

Descnipbion of Key Lisage:

Digital sigrasture
Ao By machangs anly with lowy sncnplion
Cirtical mdarmmion.

| Ok || Cacel || Mook || Heb |

Step 4. Select these options and select OK, as shown in the image.

- Digital signature
- Allow key exchange only with key encryption (key encipherment)
- Allow encryption of user data



Properties of New Template [x]

Compatbdty | General IIFIun.-llltl-hnlm | Cryptography | Key Attestation

Spscify the mequined soratunes and sscunty optiona for & key uags
=g

Signatune

[+ Digtal signature

(] Sgnature is proof of origin incrrepudiation)

|| Centificate signing

[ |CAL sigring

Encryption

i) Ao ey eschangs without key snchyplion sy agresment)

@) Mhow key exchange only wit key encryption feey enciphement)
] Ao emcryphion of user dats

[+ Maskoa this eatension crtical

Lok || Cocel || sty || Heo |

Step 5. Navigate to Extensions > Application Policies > Edit > Add, as shown in the image.



Compatibity | General | Request Handing | Cryptography | Key Attestation
Subpect Hame Server | Requrements

Superseded Templates Extensions Security
To modify an exdension, selact i, and then click Edit.

Eiiﬂ#udhﬂhlm:

TN I
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Application policies:
Server Authentication

|| Make this extension critical

Step 6. Search for Client Authentication, select it and then OK, as shown in the image.



An apphestion polbey (called enhancad ey usage in Windows 2000}
defines how a certificate can be used, Select the application pobcy required
fior wilkd sigrintunes of cavtificabes e by thes template.

| ok || Cacel || Mooy || Hep |

Step 7. Select Add again, search for IP security end system, select it and then select OK on this
and on the previous window as well.



Fn applcation pokcy (called erhanced ey usage in Windows 20001
defines how a cetficate can be used. Sslect the apphoation poboy regured
For walbd sgnatures of ceificabes issusd by this bemplals.

[ ok | Cocd |[ Mgy || Hio |

Step 8. Back on the template, select Apply and then OK, as shown in the image.



SubjectMame | Server | lsuance Recuieserts
Compatbdty | General | Request Kary Atestation
Superseded Templstes | Extensons Securty

To modily an exdension, ssiect it, and then dick Bt

Bdensons included in this template:
Apphestion Polices

Basic Constramis

Cartficais Tamplate famation
lssuance Pobcies

Key Usage

Dmscriphion of Applcation Polcss:

Chert Authertication =
IF securty end system

Server Authenbcabon

[ ok || Cocd |[ moy |[ e |

Step 9. Close the Certificate Templates Console window, and back on the very first window,
navigate to New > Certificate Template to Issue, as shown in the image.
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CAPF Template

Step 1. Find the Root CA template and right-click on it. Then select Duplicate Template, as
shown in the image.
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Step 3. Navigate to Extensions > Key Usage > Edit, as shown in the image.



Compatbdty | Genenl |  lesuance Requiements
Superssded Templates | Bdensons | Sacumy

To modiy an edension, select it, and then cick Edt.

Extensions inchsdad in this templabe:
Aophcation Pobcies

[Bimss Coormsirmiris

Cestficate Template information
lammncs Poboss

| OK || Cacsl || Aoy || Heo |

Step 4. Select these options and select OK, as shown in the image.

- Digital signature
- Certificate signing
- CRL signing



Properties of New Template [x]

Compatbdty | General IIFIun.-llltl-hnlm | Cryptography | Key Attestation

Spscify the mequined soratunes and sscunty optiona for & key uags
=g

Signatune

[+ Digtal signature

(] Sgnature is proof of origin incrrepudiation)

|| Centificate signing

[ |CAL sigring

Encryption

i) Ao ey eschangs without key snchyplion sy agresment)

@) Mhow key exchange only wit key encryption feey enciphement)
] Ao emcryphion of user dats

[+ Maskoa this eatension crtical

Lok || Cocel || sty || Heo |

Step 5. Navigate to Extensions > Application Policies > Edit > Add, as shown in the image.



Compatibity | General | Request Handing | Cryptography | Key Attestaon
Subject Name | | Regquirements
Superseded Templates Bdensions Securty

To modify an exdension. select & and then click Edi.

Exi enisions included in this template:




WM&&HMammh&

Application policies:
Server Authentication

|| Make this extension critical

Step 6. Search for Client Authentication, select it and then select OK, as shown in the image.



An apphestion polbey (called enhancad ey usage in Windows 2000}
defines how a certificate can be used, Select the application pobcy required
fior wilkd sigrintunes of cavtificabes e by thes template.

| ok || Cacel || Mooy || Hep |

Step 7. Select Add again, search for IP security end system, select it and then select OK on this
and on the previous window as well, as shown in the image.



Fn applcation pokcy (called erhanced ey usage in Windows 20001
defines how a cetficate can be used. Sslect the apphoation poboy regured
For walbd sgnatures of ceificabes issusd by this bemplals.

[ ok | Cocd |[ Mgy || Hio |

Step 8. Back on the template, select Apply and then OK, as shown in the image.



SubjectMame | Server | lsuance Recuieserts
Compatbdty | General | Request Kary Atestation
Superseded Templstes | Extensons Securty

To modily an exdension, ssiect it, and then dick Bt

Bdensons included in this template:
Apphestion Polices

Basic Constramis

Cartficais Tamplate famation
lssuance Pobcies

Key Usage

Dmscriphion of Applcation Polcss:

Chert Authertication =
IF securty end system

Server Authenbcabon

[ ok || Cocd |[ moy |[ e |

Step 9. Close the Certificate Templates Console window, and back on the very first window,
navigate to New > Certificate Template to Issue, as shown in the image.
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Step 10. Select the new CAPF CUCM template and select OK, as shown in the image.
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Generate a Certificate Signing Request

Use this example in order to generate a CallManager certificate with the use of the newly created
templates. The same procedure can be used for any certificate type, you just need to select the
certificate and template types accordingly:

Step 1. On CUCM, navigate to OS Administration > Security > Certificate Management >
Generate CSR.



Step 2. Select these options and select Generate, as shown in the image.

- Certificate Purpose: CallManager

. Distribution: <This can either be 'Iust for one server or Multi-SAN>
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Step 3. A confirmation message is generated, as shown in the image.

I:ﬁ freirdnk: CDALIlE Sadaiad Risuail Chnirited
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Step 4. On the certificate list, look for the entry with type CSR Only and select it, as shown in the
image.
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Step 5. On the pop-up window, select Download CSR, and save the file on your computer.



CSHE Details for L15PFUB-ms.mauvcabal.lab, CallManager
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- Certilicate Settings

Filg Namss CallManagaroer
Certificate Purpose CallManager
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- Certificate File Data
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Step 6. On your browser, navigate to this URL, and enter your domain controller administrator
credentials: https://<yourWindowsServerlP>/certsrv/.

Step 7. Navigate to Request a certificate > advanced certificate request, as shown in the
image.
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Step 8. Open the CSR file and copy all its contents:
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Step 9. Paste the CSR on the Base-64-encoded certificate request field. Under Certificate
Template, select the correct template and select Submit, as shown in the image.
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Step 10. Finally, select Base 64 encoded and Download certificate chain, the generated file can
now be uploaded the CUCM.
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Verify

The verification procedure is actually part of the configuration process.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.
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