RootsMagic Magic Guide

Backup and Restore a RootsMagic Database

This Magic Guide covers:

A. Who should backup their RootsMagic files and why?

B. What is a backup file?

C. When do | backup my RootsMagic file?

D. How do | remember to make a backup and keep them straight?
E. How do | manually backup the file?

F. Where should | store my backup?

G. How do | backup files to my flash drive or external hard drive?
H. How can | make a backup to Dropbox?

I. How do | Restore a Backup (.rmgb) File?

A. Who should backup their RootsMagic files and why?

EVERYONE needs to make backups! One of the biggest fears and heartaches of any family
historian is losing their records due to a computer crash, user error, file corruption, or natural
disaster. Think about how much time you have invested in your database, and how long it would
take to re-create that database from scratch. With a current backup copy of your file, you can
restore the file and get back to work in a matter of minutes. Without a backup, there is sorrow,
discouragement, and hard work.

B. What is a Backup File?

A backup is a compressed copy of your RootsMagic database which has an .rmgb extension. It
is less likely to become corrupted when emailed or transferred to another computer than a
database (.rmgc) file. A backup is better than a GEDCOM file because it is an exact copy of
your database with no potential loss.
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C. When do | backup my RootsMagic file?

It is best to get into the habit of creating a backup each time you exit the program after changes

have been made. When you have been working in
RootsMagic for several hours at a time, stop and make a
backup at whatever point you would hate to have to
recreate your work. If your computer suddenly failed or
you made a bad mistake and need to “undo” it, the
backup is worth its weight in gold. It is also advisable to
make a backup before making major changes to your file
by merging, using Compare File, DataClean, etc.

Tools

Merge
Problem Search
| Count Trees
i DataClean...
Spell Check
Gazetteer

Mapping

YT I

Color Code People
Set Living...
Set Relationships

Date Calculator...

Soundex Calculator...

Calendar...

GenSmarts Suggesfions

Create a Shareablg CD...

File Opticns...

Program Opticns...

CountyCheck Explorer...

Relationship Calculatof...
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D. How do | remember to make a backup and keep

* | them straight?

>

1. To receive a reminder to back up your file each time you
close the program go to the “Tools” menu and select “Program
Options”.

/2. On the “General” tab, make sure that “Ask for backup when
exiting” and “Add date to backup file name” are checked.

-

3. Click “OK".

&2 Program Options

=E—)

Program Options

e |
2

Display

How to interpret ambiguous dates:
[Use the windows settings

[¥] Open ddtabases from last session

3]

When a database is opened or created:

[¥] Display fiews screen

\'; 2

Folders

[¥] Ask for backup when exiting lTiIe all open databases V]

[¥] Add date to backup file name

[¥] Check for duplicates when adding people
[¥] Let comma finish surname in RootsMagic Explorer
Let <Enter> work like <Tab> key
Enable live spell checking .

Units of measurement
[] Use plain text when pasting to notes
[¥] Use CountyCheck when entering places

[¥] Build thumbnails when opening Media Gallery

[ Cancel

I[ oK
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By default each RootsMagic backup has the date assigned to the file name (YYYY-MM-DD).

Without adding the date, each backup will overwrite the || Masterl (2015-03-29).rmgb
previous backup. Adding the date allows you to have multiple __| Masterl (2015-03-31).rmgb
backups going back in time, and it will be easier to see which __| Masterl (2015-03-31_A).rmgb
backup is the most recent. It's not unreasonable to keep L Masterl (2015-03-31_B).rmgb

several years of backups archived as there may be times you —

need to return to an earlier version. —
asterl (2015-04-04).rmgb

| Masterl (2015-04-05).rmgb

‘I} NOTE: Remember to manually add a letter to the date if ]
you do more than one backup on the same day.

E. How do | manually backup the file?

Eie [Edit Lists Add View Seq 1. Before making significant changes to your file, or while working
" Ctrl+N

+0

New...
[ B Open...
Open Recent

for extended periods, we recommend that you make a backup.
Simply click on the “File” menu and select “Backup”.

Search for Files...

Close
2. The “Backup” window will open.
Rename...
Delete... ’,.‘ = 52 Ty
‘a Backup =
e @

RootsMagic Backup

Save an archived copy of your database

_ 3
Backup file name —
trl+P WORK_II (2015-05-13).rmgh ] Backup media files

Database tools...

Compare files...

Import lists...

Print a Report...

W

Print Setup... @ On my computer (floppy disk, USB, hard drive, etc.)
b o, 4
m Export...

C:\Users\[Name]\Documents\ROOTSMAGIC\Backup

FamilySearch fentral...
") On my CD burner

Save to Drogpox for Apps.
() To Dropbox
lﬁ Backup... () To Google Drive
Restore...
Properties... || Begin backup I Cancel
B et . 4

3. The file name is listed.

4. The default is set to save “On my computer”. The path to where the backup file will be saved
is also displayed.

5. Click “Begin backup”.
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F. Where should | store my backup?

Once you have made a backup (.rmgb) to your hard drive, it is good practice to make an
additional backup somewhere else. You can back up your file to an external hard drive, flash
drives, or CDs. You can also backup your file to the “cloud”, which will give you access to your
backup from another computer or when you are away from home.

Some external hard drives and cloud services automatically sync copies of your files
from your computer. Check into services such as Mozy, Carbonite, Backblaze and Dropbox,
but don’t let them fool you into a false sense of security. Auto backup services save a copy of
your database file (.rmgc), but there will be times you need to restore your file from a backup
(.rmgb), especially if the database is corrupted. Backup files won’t be there when you need
them unless you also save them to these storage areas. You can do it manually, or you can set
up these backup systems to automatically sync both your database (.rmgc) and you backup
(.rmgb) files, from your computer’s hard drive to their storage area.

Web based email services, such as Gmail, Hotmail, Yahoo, etc. can also act as a cloud service.
Simply email your backup (.rmgb) to yourself and access it later from anywhere.

If you haven’t made a backup of your RootsMagic database, stop and do it now!

52 RootsMagic 7 - [C:\Users\Cina\Docums

Zl Filelgdit Lists Add View Se:

G. How do | backup files to my flash drive or / R —
b

external hard drive? Open... ct+0 |
/_S; Open Recent [

Search for Files...

1. Plug your flash drive or external hard drive into your Close
Computer. Rename...
Delete...

Copy...

Database tools... |

2. Click the “File” menu in RootsMagic and select
“Backup”.

Compare files...

Import lists...

W

Print a Report... Ctrl+P

Print Setup...

Import...

s oo zES

T

Export...

B

FamilySearch Central...

1
E: Save to Dropbox for Apps...

|
%m Backup...

Restore...
P

Pt

Pt m Exit |
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3. On the “Backup” window, check to see WHERE the file will be saved. With the “On my

computer” option selected, the file will be saved to your hard drive.

/
-
50 Backup )[

=@ = |

TS

RootsMfagic Backup

Save an afchived copy of your database

Backup file name
Backup media files

B, hard drive, etc.)

Browse...

C:\Users\[Name]\Documents\ROOTSMAGIC\Backup

) On my CD burner
() To Dropbox
() To Google Drive

rBegin backup ] [ Cancel ]

4. If it is NOT set to
save to the correct
drive letter, click the
“Browse” button.

5. A new window will open so that you can select the folder where you want to save your

backup.

B
e oSelect Folder >

~ [ 3| [ Search PrBACKz 001 (k)

U‘v!_ » Computer » PKBACKZ001 (K:) »

Organize v New folder 4= v

»

4% Favorites Name Date modified Type
|| Magic Briefcase ) Vital Records_BC_8-27-2012

!, Vital Records_DB-MC_9-16-2012

8/27/2012 11:20 AM
1/14/20131:03 PM

File folder
] Recent Places File folder
Bl Desktop
& RecycleBin
23 Dropbox
& Downloads

4 Libraries
13 Documents
,J7 Music
|/ Pictures

B Videos

48 Computer
& os(c)
HP_RECOVERY (D:)
a My Passport (F:)
e PKBACKZ 001 (K:) 1

“ﬂ Network

v | B4l

g m

k[

Folder: PKBACK#001 (K:)

I[ Select Folder I] l Cancel

‘'

6. Find the “drive”
that represents your
flash drive or
external hard drive.
Click to select it.

In this example, the
drive letter is K:

7. The drive will be
displayed in the
“Folder:” field.

8. Click the “Select
Folder” button.
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9. You will be returned to the “Backup” screen, where you will see the drive for your

flash drive.

RootsMagic Backup

AN

WORK_II (2015-04-01).rmgb 7| Backup media files

@ On my computer (floppy disk, USB, hard drive, etc.)

(*) On my CD burner
() To Dropbox
) To Google Drive

Iv Begin backup I [ Cancel J

11. Click the “Begin backup” button. A backup (.rmgb) copy of your file will be created and

stored on your flash drive.

GJB“@ — = = | 10. Beginning with

RootsMagic 7, you can
~ backup your file with the

Save an archived copy of your database .
media.
Backup file name

BWW
files take Up &

LOT of roowny, yow

this optiow

'wwdmuy!

G4 RootsMagic 7 - [C:\Users\Cina\Documg

=)
H. How can | make a backup to Dropbox? 3 -
;
/ P:
To save your backup file to Dropbox, you must have a LE
Dropbox account. If you do not have a Dropbox account,
you can set one up by going to https://www.dropbox.com/ In
Make a note of your login information (email and [‘
password). N
Pl
1. Click on the “File” menu in RootsMagic and select Pl
“Backup”. Pl
Pl
Pl
PI bed
i
P{ .o
P
.&l
P m
Pi
P
P m

:.l'[fileli Edit Lists Add View Se

New... Ctrl+N
Open... Ctrl+ O
Open Recent

Search for Files...

Close

Rename...

Delete...

Copy...

Database tools...

Compare files...

Import lists...

Print 2 Report... Ctrl+P
Print Setup...

Import...

Export...

FamilySearch Central...
Save to Dropbox for Apps...
Backup...

Restore...

Properties...

Exit
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https://www.dropbox.com/

2. On the “Backup” window, click the “To Dropbox” option.

/

&2 Backup

/

RootsMagic Backup

Save an archived copy of your database

Backup file name
WORK_II (2015-05-13).rmgb

() On my computer (

C\Users\Cin

py disk, USB, hard drive, etc.)

ocuments\ROOTSMAGIC\Backup

) on my ¢ burner
@ To Dropbox

() To Google Drive

3. Click the “Begin
backup” button.

[T Backup media files

Begin backup ]I[ Cancel

6. An “Authorization window will open to
let you know that RootsMagic wants to
access Dropbox. Click “Allow” to
proceed.

T Authorize SE>™
$ '
b4 4. The Dropbox login window will
Sign in to Dropbox to link with RootsMagic open Enter the emall address
< : and login password you
created with Dropbox.
[ sone | 5. Click “Sign In”.
g
Q‘Q

RootsMagic would like acces
Apps » RootsMagic, inside your Dropbox

Cancel
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7. You will see the “Backing up to Dropbox...” window, followed by a confirmation window so

that you know that the backup was completed successfully.

od ';:
L

RootsMagic 7

RootsMagic

®e Backing up to Dropbox...

The backup has been saved to Dropbox

8. Your backup was put into Dropbox > “Apps” folder > “RootsMagic” subfolder.

(Dropbox\Apps\RootsMagic)

9. Click “OK” on the confirmation window to close the window and return to RootsMagic.

10. Backing up to Dropbox uploads your file to the Dropbox
server. It can take longer depending on the backup size and your
internet speed. Media will require additional upload time.

I. How do | Restore a Backup (.rmgb) File?

If you make a mistake while changing something in your file, or
should the file become corrupted in some way, you can return
the file to a previous state by restoring it from a backup.

NOTE: Work that was entered between the time that you

made this backup and when you restored it will be lost.
You will need to redo this work. This is another reason to make
frequent backups.

1. You must close any currently opened database in order to
restore a file. Click on the “File” menu and choose, “Close”.
RootsMagic will remain open, but the database file will be
closed.

2. Click on the “File” menu again and click “Restore”. —,'}
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| File | Edit Lists Add View
i Ctrl+N
Ctrl+O

New...

Open...

4 Open Recent

f Search for Files...

Close

Rename...
Delete...

Copy..
Database tools...
| Compare files...

| Import lists...

¢=2 Printa Report... Ctrl+P

Print Setup...

Import...

Export...

FamilySearch Central...

Save to Dropbox for Apps...

Backup...

kv
Restore...

Properties...
|

@

Exit
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WOre Backup >

=@ = |

Restore Backup

Select the backup file to restore

Restore an archived backup of your database

C:\Users\Cina\Documents\ROOTSMAGIC

I Browse... I[ Search... ]

Begin restoring backup H Cancel ]

open.

3. The “Restore Backup” window will

4. Click the “Browse” button to find your

-
:"‘;:«_ Cpen >

()7 [ ¥ « rooTSMAGIC

» Backup » v I 5 H Search Backup

Organize v New folder

9@, Documents
9._;‘_% My Documents
1. 000 Temp
1. Adobe
., AncestorSync
. Ancestral Quest
.. Businesss_Finance
i, Church
1 Cinas classes
. Dropbox
.. Family Histerian Projec
) Family Tree Maker
. FOR
. Genealogy
i, JobSearch
. Journal
1 Legacy Family Tree
. Magic Briefcase
1 Misc
(] My Data Sources
. My Weblog Posts
. MyHeritage
i Navicat
\. Ohana
| Outlook Files
. PAF
.. Personal Historian
.. Program Download
./ Recipes
J Relief Society
=> |\ ROOTSMAGIC
a |, Backup
. Charts
.. GEDCOM

ORK_II (2015-05-13).rmgb

Documents library

Arrange b
Backup

-~

'\

Name

L VOV \EULITUITLI LY

| WORK_Il (2015-03-26).rmgb
|| WORK_II (2015-03-27).rmgh
L] WORK_T (2015-03-28).rmgh
|| WORK_II (2015-03-30).rmgh
| WORK_II (2015-03-31).rmgb
|| WORK_II (2015-04-02).rmgh
|| WORK_Il (2015-04-03).rmgh
] WORK_II (2015-04-06).rmgh
| WORK_TI (2015-04-07).rmgh
|| WORK_II (2015-04-09).rmgh
L] WORK_II (2015-04-10).rmgh
|| WORK_II (2015-04-13).rmgh
| WORK_Il (2015-04-14).rmgb
] WORK T (2015-04-15).rmgh
L] WORK_TI (2015-04-16).rmgh
| ] WORK_II (2015-04-21).rmgh
|| WORK_II (2015-04-24).rmgh
|| WORK_II (2015-04-27).rmgh
| WORK Il (2015-04-28).rmgb
| WORK_Il (2015-04-30).rmgh
| WORK_I (2015-04-02218PM.rmgb
| WORK_II (2015-05-01).rmgh
] WORK_II (2015-05-04).rmgh
|| WORK_II (2015-05-05).rmgh
| WORK_I (2015-05-08).rm,

m

backup file.
[ ]
2] 5. The “Open” file window will
- O @ || pe displayed.
y: Folder v

»

v [RootsMagic Backup (*.rmgb) vl

I Open Iv‘

Cancel

In this example, the backup
files can be found by going to
Documents >
My Documents >
ROOTSMAGIC >
Backup >

6. Highlight the file that you
want to restore.

7.You will see the file name in
the “File name:” field.

L

8. Click the “Open” button to
finalize your selection and
close the window.
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9. You will be returned to the
“Restore Backup” window where you
can see the path to the file you
chose to restore.

10. The “Restore to...” button will —__
show the location where the file will
be restored.

-
&2 Restore Backup

[=lE] =]

Restore Backup

Restore an archived backup of your database

Select the backup file to restore
C:\Users\Cina\Documents\ROOTSMAGIC\Backup\WORK_ Il (201° | Browse... ] [ Search...

C:\Users\Cina\Documents\ROOTSMAGIC

Begin restoring backup Cancel

If the RootsMagic (.rmgc) file will be restored to the correct folder, click the “Begin

restoring backup” button.

If you want to change the location, click the “Restore to...” button.

B Note: If the backup (.rmgb) file contains media files you will receive a message asking if

you want to “Restore media files?” Select “No” to restore the database but not the images.

Select “Yes” to restore both the database and media files. The location where you restored your
backup will now contain a new subfolder called “Media”. All of the MediaTags in the database
will be changed to link to the images within the Media folder.

4 |, ROOTSMAGIC
Backup
) Charts
; GEDCOM E TN

Index
KEEP_Cina
) Masterl -

I[ OK I [ Cancel ]

-

Backup” window.

( Browse For F°® ~*_ | 11. The “Browse For Folder’ window will
Select Folder open. Use the slide bar on the right of the
v window to find the folder where you want
Desktop 5 M your RootsMagic (.rmgc) file to be stored.
* 73 Libraries E
4 8 Cina '
.gimp-2.6
. .thumbnails M W w
}I‘;\\do[b)e Acrobat XI Pro Yow M Wz:j:
. AppData W
the it fr
i3 Contacts A M
m Desktop - MQM,&/ dMO’PP
I o
OK Cancel p e/
J;;M 44 M
Recipes & MM
| Relief Society /

12. When you find the folder where you want your
.rmgc file stored, click on the folder to highlight it.

13. Click “OK” to finalize your choice and close the
window.
14. You will, once again, be returned to the “Restore
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-
4o Restore Backup

l=|E=] = |

Restore Backup

Restore an archived backup of your database

Select the backup file to restore

C:\Users\Cina\Documents\ROOTSMAGIC

C:\Users\Cina\Documents\ROOTSMAGIC\Backup\WORK_II (201t [ Browse... H Search...

Begin restoring backup

|[ [ Cancel

15. Click the “Begin restoring backup” button.

16. If you already have a file with that name and in the same folder, you will receive a

warning. Restoring the file will overwrite the current file with this file. You can change the
“Restore to...” location if this is not what you planned to do.

Overwrite Existing Database?

S

) Overwrite Existing Database?

A database with this name already exists. Do you want
to overwrite the existing database with this backup?

|ﬂ Overwrite database I Cancel I

17. Click “Overwrite database” to allow the backup to be restored.
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Your file is now restored to an earlier version. Check it to make sure that it works correctly
and redo any work that may have been lost.




